Welcome, Guest. Please login or register.

Pages: [1]
Print
Author Topic: Can't run PARPG, pargp.py says he can't find FIFE  (Read 3728 times)
Knitter
Community member

Posts: 16


View Profile Email
« on: March 15, 2012, 01:51:46 AM »

Hi,

After looking at the code for some time I wanted to try and run the current code, but I'm always stuck at the starting script with the same message, it seems FIFE is not being found and I have no idea how to get PARPG to see my FIFE module.

I just compiled the latest FIFE code from SVN and tested with Unknown Horizons, but in PARPG neither the "-p" nor the "--fife-path" work.

Any thoughts on how to debug the problem?


Also, I haven't found a good python editor any suggestions that run on OS X and don't include Wingware or Eclipse (Pydev)?
Logged
Beliar
Community member

Posts: 71

KarstenBock@gmx.net
View Profile Email
« Reply #1 on: March 15, 2012, 07:47:00 AM »

PARPG must be able to find the fife directory, which has the fife.py module inside. If you are using fife from svn you must use "<FIFE>/engine/python/"

As for the editor, i don't really know any else besides these 2.
Logged

Wing IDE - http://wingide.com/wingide - Free for OS use
Knitter
Community member

Posts: 16


View Profile Email
« Reply #2 on: March 15, 2012, 11:23:25 AM »

Ahh! I should have tested it that way Smiley

When I started running UH I tried putting the path to the module but UH needs only the root folder, PARPG seems to need the folder with the module.

FIFE is found but running PARPG fails with:

Code:
"Assertion failed: (!m_instance), function DynamicSingleton, file engine/core/util/base/singleton.h, line 90."
Logged
Beliar
Community member

Posts: 71

KarstenBock@gmx.net
View Profile Email
« Reply #3 on: March 15, 2012, 12:20:11 PM »

Hmm, don't know why it fails with that message.
It could be that a recent fife change broke things again, though. My current checkout is at revision 3863. I will try to update it and see if i get the same message.
Logged

Wing IDE - http://wingide.com/wingide - Free for OS use
Knitter
Community member

Posts: 16


View Profile Email
« Reply #4 on: March 15, 2012, 12:24:32 PM »

I'll revert to that version and see if it works, I don't need FIFE for anything other then UH and PARPG.
Logged
Beliar
Community member

Posts: 71

KarstenBock@gmx.net
View Profile Email
« Reply #5 on: March 15, 2012, 12:35:24 PM »

I just tested with the newest fife trunk, it still works for me.
Logged

Wing IDE - http://wingide.com/wingide - Free for OS use
skeet70
Community member

Posts: 9



View Profile Email
« Reply #6 on: March 19, 2012, 06:39:12 PM »

Also, I haven't found a good python editor any suggestions that run on OS X and don't include Wingware or Eclipse (Pydev)?

I don't have any suggestions as far as the problem you're having, but I use Sublime Text 2 (http://www.sublimetext.com/2). Not an IDE, but if you're just looking for a good editor for python that's a great one.
Logged
Knitter
Community member

Posts: 16


View Profile Email
« Reply #7 on: March 19, 2012, 06:47:28 PM »

That looks nice to use, I'll have to wait until I restore my system to try PARPG again and then I'll look closer at that editor.
Logged
Pages: [1]
Print
Jump to: